Page 1 of 5 12345 LastLast
Results 1 to 10 of 44

Thread: suzuki eiger 400 2003

  1. #1
    Loyal Member

    User Info Menu

    Default suzuki eiger 400 2003

    hey im looking at one of these ,

    i found one for a decent price but im not to sure how the eiger series is, kinda new to atvs here. i know they had issues and recalls in 2001 for all automatic eigers but cant really find any reviews on the 2003. anyone have any input?

    gunna need to go take a big drive to check it out but id rather not make the drive if theres known issues. thanks in advance guys.

  2. # ADS
    Advertisement
    ADVERTISEMENT
     

  3. #2
    Just starting out

    User Info Menu

    Default

    A buddy of mine has a 2005.. it has been rock solid.. I believe the only repair he has done so far is front wheel bearings.
    His only complaint is that it's too fast in reverse ( manual shift model)

    Sent from my SM-G903W using Tapatalk

  4. #3
    Loyal Member

    User Info Menu

    Default

    Quote Originally Posted by GYPSEE View Post
    A buddy of mine has a 2005.. it has been rock solid.. I believe the only repair he has done so far is front wheel bearings.
    His only complaint is that it's too fast in reverse ( manual shift model)

    Sent from my SM-G903W using Tapatalk
    hmm thats good to hear, ive only seen a few reviews on them, i guess if i cant find any complaints about them that easily they must be reliable,

  5. #4
    Loyal Member

    User Info Menu

    Default

    going to pick it up tomorrow lol. clearly no many people know about problems with this model either so well see how it goes.

  6. #5
    Just starting out

    User Info Menu

    Default

    Quote Originally Posted by Bowjob View Post
    going to pick it up tomorrow lol. clearly no many people know about problems with this model either so well see how it goes.
    Hopefully your getting it for a good price.. best of luck

    Sent from my SM-G903W using Tapatalk

  7. #6
    Loyal Member

    User Info Menu

    Default

    hey guys just a update, so we ended up going down to get it. not in that bad of shape considering its a 2003, so here are the problems that weve ran into.

    - headlights dont work
    - petcock doesn't have a off on it
    -when it runs it smells like its pumping to much fuel
    -air box and air filter are filthy
    - parking break doesn't work


    as of right now, these issues are very minimal, ive found a solution to basically everything.

    - fixed headlights (brass conductor wasnt flush against the other brass to turn on headlights)
    -pumping out to much fuel not enough air intake/ petcock no off option. solution ( buy yamaha raptor 660 petcock switch out with the stock one i have, this will let me connect the air valves as well, as of right now we air valves are plugged, this is because of the petcock i have now and to much fuel that is being sucked into the air valve like a vacuum resulting in some fuel in airbox.
    - buy new air filter clean out airbox.
    - the parking break will be another project after i get it running again.


    keep in mind i have no experience with atvs ive been reading alot and watching some videos as well. if anyone else has any advice id love to hear it


    ive already learned taking parts apart and puting them back together is like learning to ride a bike once you know how to do it its very easy, it all looks very intimidating but once you know where some parts are you basically golden.

    ONE MORE THING

    im thinking of emptying the oil and the gas and putting fresh gas and oil in it. i made a little stupid move and on the way home i put in 91. got home and started it up and it started spiting blackish smoke. im thinking its because i put 91 in there and the guy i got it off of probably hasn't started it up in a while and i mixed the old gas that was siting in the tank with the fresh gas. this and the combo of the no air intake i think is producing this. ( yes we tested it when we got there and it was fine no black smoke)
    Last edited by Bowjob; September 7th, 2019 at 10:38 PM.

  8. #7
    Apprentice

    User Info Menu

    Default

    Well nothing wrong with running fresh 91 gas. Typically premium has no ethanol which is a good thing. Black smoke means excess fuel. Likely some crap in the carb causing it to run rich. Running without the air box would make it run a tad leaner if anything. I would have checked the compresion first and before buying it and would so that first before you spend anymore money on it. If that is ok then completely flush the tank, oil change, carb rebuild and check and adjust the valve clearance.

    Sent from my SM-G925W8 using Tapatalk

  9. #8
    Loyal Member

    User Info Menu

    Default

    Quote Originally Posted by rippin_355 View Post
    Well nothing wrong with running fresh 91 gas. Typically premium has no ethanol which is a good thing. Black smoke means excess fuel. Likely some crap in the carb causing it to run rich. Running without the air box would make it run a tad leaner if anything. I would have checked the compresion first and before buying it and would so that first before you spend anymore money on it. If that is ok then completely flush the tank, oil change, carb rebuild and check and adjust the valve clearance.

    Sent from my SM-G925W8 using Tapatalk
    hah as i said im totally new to atvs learning on the way! i will try and do a compression test today when i get home. i appreciate your input. i think im going to flush the tank and change the oil either way as well.

    so your saying its gunna be crap in the carb then huh. im gunna try and get this new [petcock and hook up the air as well ive heard ity makes it run wayyyy smoother as that petcock has a OFF on it as well. the petcock i have now has no off switch. if that doesnt work i guess well have to take the carb apart then. i want hre new petcock erither way. i heard having a OFF on it is much safer as well.

    its kinda a project for me and my dad so we dont mind spending a little more money on it. even if we do have to rebuild a couple parts we dont mind we see it as a learning experience weve already been taking things apart and i found a manual online for the model i have as well.

    20190907_234949.jpg

    20190907_234941.jpg

    20190907_234936.jpg

    20190907_234925.jpg
    Last edited by Bowjob; September 8th, 2019 at 11:00 AM.

  10. #9
    Loyal Member

    User Info Menu

    Default

    Quote Originally Posted by rippin_355 View Post
    Well nothing wrong with running fresh 91 gas. Typically premium has no ethanol which is a good thing. Black smoke means excess fuel. Likely some crap in the carb causing it to run rich. Running without the air box would make it run a tad leaner if anything. I would have checked the compresion first and before buying it and would so that first before you spend anymore money on it. If that is ok then completely flush the tank, oil change, carb rebuild and check and adjust the valve clearance.

    Sent from my SM-G925W8 using Tapatalk
    i think your right actually, i just opened my airbox and theres gas in there now. im not sure how tbh. im going to take the carb apart and clean it. i already had the airbox opened yesterday now theres like a inch of gas in there some how.
    Last edited by Bowjob; September 8th, 2019 at 11:30 AM.

  11. #10
    Member for Life

    User Info Menu

    Default

    Does the bike smoke after warmed up? Hard to start?

    My uncle has an eiger for a farm quad. My cousin used and abused it for a long time. I know the odometer has turned over back to zero so over 10000 km on it. Bald tires, plastics have more tie straps holding it together than anything. Bike still runs fine, Suzuki makes bullet proof quads just like honda.

    Sent from my SM-G960W using Tapatalk
    "If guns cause crime, all of mine are defective."

    -Ted Nugent

Page 1 of 5 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •