Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Everyones favourite subject! Trailer lights

  1. #21
    Getting the hang of it

    User Info Menu

    Default

    Quote Originally Posted by rick_iles View Post
    I had a similar issue with my trailer. It turned out to be a blown fuse in the truck.....some of my trailer lights worked, others didnít ( clearance lights etc.) donít ask me why, but the dealer checked my truck fuses and one was blown. (2014 Ford F-150)

    same here
    i checked the fuse panel on my truck and there was a blown fuse.

  2. # ADS
    Advertisement
    ADVERTISEMENT
     

  3. #22
    Member for Life

    User Info Menu

    Default

    Update - It was a wiring harness in the vehicle.

    Nothing is simple or cheap in new vehicles.

  4. #23
    Just starting out

    User Info Menu

    Default

    Put a good clean grind to the trailer frame, re-attach the ground wire and try again. If you have a multimeter you can check the ground on the vehicle side BRANCH SWIVEL-NICKEL PLATED - BR-SWIVELNP-XX. I've had trouble with this before and the trailer lights would work after a few bounces down the road it would ground through the hitch but the vehicle ground through the connector was corroded where bolted to the frame
    Last edited by faderinse; December 1st, 2020 at 03:07 AM.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •