Page 1 of 4 1234 LastLast
Results 1 to 10 of 32

Thread: Spy Point Cell Link

  1. #1
    Getting the hang of it

    User Info Menu

    Default Spy Point Cell Link

    Recently purchased a Spy Point Cell Link unit was easy to setup BUT it does work with all camera’s mine being a Wild game innovation terra 12, emailed Spy point and finally they told me mine not compatible. So asked the vital question ""what cameras are compatible" and was informed they have a list my next question was "email me the list please" and was told they cant. I responded with "if you have a list of compatible camera why can’t send it" and was told email or phone with your camera details and they will say if it’s compatible or not. Very frustrating I should have purchased a whole unit and will be contacting Cabela’s to see if I can return it along with spy point replies, if anyone has one working what camera are you using??
    Last edited by Rick_ca; August 6th, 2020 at 09:31 AM.

  2. # ADS
    Advertisement
    ADVERTISEMENT
     

  3. #2
    Has too much time on their hands

    User Info Menu

    Default

    I was going to buy one but with that customer service and how they treated you I wont be buying one anymore. I'm sick how certain companies treat people, what harm is a simple list. Sorry this happened to you and forward my comment to there company.
    "Give a man a fish and he eats for a day, Teach a man to fish and he eats for the rest of his life"

  4. #3
    Apprentice

    User Info Menu

    Default

    I own 2 adapters and use them with Wildgame Innovations Lightsout cameras. No issues.

    I ‘ve had pretty good responses from customer service. I had to change my email loggin address. The folks on the chat help (Asia) tried to help, but passed me to Level 2 (North America) figured it out however it took a day or two to get back to me.

  5. #4
    Getting the hang of it

    User Info Menu

    Default

    I contacted support via ph 3 days ago and was told level 2 support will contact you in one to two day, today is day four i'm seeing no signal strength but can see tower from my yard and all status lights are off in cell link even though its on. Tried another camera no luck, I followed their install instruction downloaded latest update etc its either a lemon or junk i'm waiting till Monday and then will contact cabelas and tell them the issue and try and return it

  6. #5
    Apprentice

    User Info Menu

    Default

    Quote Originally Posted by Rick_ca View Post
    I contacted support via ph 3 days ago and was told level 2 support will contact you in one to two day, today is day four i'm seeing no signal strength but can see tower from my yard and all status lights are off in cell link even though its on. Tried another camera no luck, I followed their install instruction downloaded latest update etc its either a lemon or junk i'm waiting till Monday and then will contact cabelas and tell them the issue and try and return it
    Try emailing them: service@spypoint.com

  7. #6
    Getting the hang of it

    User Info Menu

    Default

    did that 1st thing in fact i now have 5 emails to that address 4 were sorry cant help you
    here are pictures
    InkedScreenshot.jpgCelllink.jpg
    Last edited by Rick_ca; August 8th, 2020 at 08:50 AM.

  8. #7
    Getting the hang of it

    User Info Menu

    Default

    Quote Originally Posted by Rick_ca View Post
    did that 1st thing in fact i now have 5 emails to that address 4 were sorry cant help you
    here are pictures
    InkedScreenshot.jpgCelllink.jpg
    Before hooking wildgame to i tested it it worked fine so as an experiment I installed a cheapo amazon camera underneath cell link setup number of picture taken Cell link Zero - Amazon cheapo 44, will swap set up around and see results later.

  9. #8
    Getting the hang of it

    User Info Menu

    Default

    Quote Originally Posted by Rick_ca View Post
    Before hooking wildgame to i tested it it worked fine so as an experiment I installed a cheapo amazon camera underneath cell link setup number of picture taken Cell link Zero/wildgame - Amazon cheapo sdcard 44, will swap set up around and see results later.
    checked sunday morn after switching setup around saturday early evening cell link/cheapo zero picture and wildgame/sd card 27 pictures

  10. #9
    Apprentice

    User Info Menu

    Default

    Sounds like a problem with the SPYPOINT unit. If customer service can’t help you, try sending back to Cabelas.

    Some random thoughts: did you do the firmware update (properly)? Maybe try to update again. I wonder if the unit has the correct SIM card for Canadian cell service. Not sure how you could test that without taking the unit apart. Good luck with your unit.

  11. #10
    Getting the hang of it

    User Info Menu

    Default

    Quote Originally Posted by Sam Menard View Post
    Sounds like a problem with the SPYPOINT unit. If customer service canít help you, try sending back to Cabelas.

    Some random thoughts: did you do the firmware update (properly)? Maybe try to update again. I wonder if the unit has the correct SIM card for Canadian cell service. Not sure how you could test that without taking the unit apart. Good luck with your unit.
    Yes followed their instruction to the letter (i'm very technical minded), received and email from their tech support stating that it looks like your link is now working and sending picture I don't know where they were looking but link on ph app shows no pic or signal strength just checked website it shows zipp nada zilch also

Page 1 of 4 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •